103 Star 608 Fork 225

若水印象 / tp6

 / 详情

安装报错了!

Backlog
Task
Opened this issue  
2021-03-19 11:32

安装后,访问跳出这个提示,PHP版本采用7.1.9
Fatal error: Declaration of think\Container::get($abstract) must be compatible with Psr\Container\ContainerInterface::get(string $id) in D:\phpstudy_pro\WWW\jwl\vendor\topthink\framework\src\think\Container.php on line 34

Attachments

Comments (2)

幽魂轩 created任务
幽魂轩 set related repository to 若水印象/tp6
展开全部操作日志

换个php版本试试

这个应该是作者自己造成的,如果开发的时候用的php版本大于7.1,Tp6的 psr(容器)接口 会自动加载为 7.2以上的版本才能用的接口,可以尝试 切换到7.1.9 重新安装tp6进行提取 低版本 psr Container(容器)接口进行替换

Sign in to comment

Status
Assignees
Projects
Milestones
Pull Requests
Successfully merging a pull request will close this issue.
Branches
Planed to start   -   Planed to end
-
Top level
Priority
Duration (hours)
Confirm
参与者(3)
524793 ruoshui yx 1578926564 5568288 planktonzhang 1578988617
PHP
1
https://gitee.com/ruoshuiyx/tp6.git
git@gitee.com:ruoshuiyx/tp6.git
ruoshuiyx
tp6
tp6

Search

102255 3a0e046c 1850385 102255 7aaa926c 1850385