1 Star 1 Fork 0

aoseala / zei

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
克隆/下载
shell.nix 1.30 KB
一键复制 编辑 原始数据 按行查看 历史
Philippe Camacho 提交于 2020-09-22 13:10 . 458 serde zkp pp params (#136)
with import <nixpkgs> {};
let src = fetchFromGitHub {
owner = "mozilla";
repo = "nixpkgs-mozilla";
rev = "e912ed483e980dfb4666ae0ed17845c4220e5e7c";
sha256 = "08fvzb8w80bkkabc1iyhzd15f4sm7ra10jn32kfch5klgl0gj3j3";
};
moz_overlay = import (builtins.fetchTarball https://github.com/mozilla/nixpkgs-mozilla/archive/master.tar.gz);
NIGHTLY_DATE="2020-09-15";
nixpkgs = import <nixpkgs> { overlays = [ moz_overlay ]; };
rustNightly = (nixpkgs.rustChannelOf { date = "${NIGHTLY_DATE}"; channel = "nightly"; }).rust.override {
extensions = [
"clippy-preview"
"rustfmt-preview"
];
};
in
with import "${src.out}/rust-overlay.nix" pkgs pkgs;
stdenv.mkDerivation {
name = "rust-env";
buildInputs = [
# Note: to use use stable, just replace `nightly` with `stable`
rustNightly
# Add some extra dependencies from `pkgs`
openssl
zlib
pkgconfig openssl binutils-unwrapped
protobuf
cargo-udeps
] ++ stdenv.lib.optionals stdenv.isDarwin [
darwin.apple_sdk.frameworks.Security
];
# Set Environment Variables
RUST_BACKTRACE = 1;
LD_LIBRARY_PATH = "${zlib}/lib";
PROTOC = "${protobuf}/bin/protoc";
PROTOC_INCLUDE = "${protobuf}/include";
shellHook = ''
export PATH="$PATH:./target/debug"
'';
}
Rust
1
https://gitee.com/Aoseala/zei.git
git@gitee.com:Aoseala/zei.git
Aoseala
zei
zei
master

搜索帮助

53164aa7 5694891 3bd8fe86 5694891