1 Star 0 Fork 0

Maxinsomnia / substrate-node-template

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
克隆/下载
shell.nix 728 Bytes
一键复制 编辑 原始数据 按行查看 历史
kaichao 提交于 2020-10-24 19:06 . Nix shell sync with Substrate (#100)
let
mozillaOverlay =
import (builtins.fetchGit {
url = "https://github.com/mozilla/nixpkgs-mozilla.git";
rev = "57c8084c7ef41366993909c20491e359bbb90f54";
});
nixpkgs = import <nixpkgs> { overlays = [ mozillaOverlay ]; };
rust-nightly = with nixpkgs; ((rustChannelOf { date = "2020-10-05"; channel = "nightly"; }).rust.override {
targets = [ "wasm32-unknown-unknown" ];
});
in
with nixpkgs; pkgs.mkShell {
buildInputs = [
clang
cmake
pkg-config
rust-nightly
] ++ stdenv.lib.optionals stdenv.isDarwin [
darwin.apple_sdk.frameworks.Security
];
LIBCLANG_PATH = "${llvmPackages.libclang}/lib";
PROTOC = "${protobuf}/bin/protoc";
ROCKSDB_LIB_DIR = "${rocksdb}/lib";
}
Rust
1
https://gitee.com/Maxinsomnia/substrate-node-template.git
git@gitee.com:Maxinsomnia/substrate-node-template.git
Maxinsomnia
substrate-node-template
substrate-node-template
master

搜索帮助